Commit 20fbedc0 authored by Vincent Guigue's avatar Vincent Guigue
Browse files

files

parent 7ff974b7
%% Cell type:markdown id: tags:
# Configuration check & package installation
In several steps:
1. The modules that are supposed to already be installed
1. Modules for historical time series prediction
1. The machine learning packages
1. The deep learning modules
Warning: most of the time, the most recent version of the module is the best... But there is at least one exception!
%% Cell type:code id: tags:
``` python
# with anaconda (or any scientific python distribution) the following modules should already be installed...
! pip install matplotlib --upgrade
! pip install pandas --upgrade
! pip install seaborn --upgrade
! pip install plotly --upgrade
```
%% Cell type:code id: tags:
``` python
# Time series prediction
#### # ! pip install pystan --upgrade
! pip install pystan==2.19.1.1
! pip install statsmodels --upgrade
! pip install fbprophet --upgrade
```
%% Cell type:code id: tags:
``` python
# machine learning
! pip install sklearn --upgrade
! pip install xgboost --upgrade
```
%% Cell type:code id: tags:
``` python
# deep learning
! pip install torch --upgrade
! pip install torchvision --upgrade
! pip install tensorboard --upgrade
! pip install optuna --upgrade
```
%% Cell type:code id: tags:
``` python
import numpy as np
a = np.random.rand(2, 3)
print(a)
print(a[:,None])
```
%% Output
[[0.73615106 0.97506029 0.31636982]
[0.79170222 0.3136446 0.9643225 ]]
[[[0.73615106 0.97506029 0.31636982]]
[[0.79170222 0.3136446 0.9643225 ]]]
%% Cell type:code id: tags:
``` python
```
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment