Commit b4a7d1a6 authored by Gabriel Gouvine's avatar Gabriel Gouvine
Browse files

Add SUPPORT.rst file

parent 4e23dff0
......@@ -40,7 +40,7 @@ Building Coriolis
To build Coriolis, ensure the following prerequisites are met:
* Python 2.7 or 3.
* Python 3.
* cmake.
* boost.
* bison & flex.
......@@ -65,6 +65,7 @@ Then, build the tool: ::
ego@home:coriolis$ make install
If you encounter issues, please consult SUPPORT.rst for tips.
Coriolis gets installed at the root of the following tree: ::
~/coriolis-2.x/<OS>.<DISTRIB>/Release.Shared/install/
......
=================
Help and tooltips
=================
Compilation errors
==================
This section is here to help you with the build process, and help you fix dependency issues or workaround compilation errors if it happens on your distribution.
RapidJson
---------
Some versions of RapidJson do not build with newer compilers, while others build only with newer ones.
The version provided in README.rst should work for older compilers. Otherwise, consider pulling a newer version.
Qt5
---
To use Qt5, you should add the --qt5 option to the ccb.py line in Makefile.
On some distributions, you may need to replace the lines in bootstrap/cmake_modules/FindBootstrap.cmake from ::
find_package(Qt5Core REQUIRED)
to ::
find_package(Qt5 COMPONENTS REQUIRED Core)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment